GLib version too old (micro mismatch)

2017年9月18日

Debian sidで何気なくpackageをいくつかupdateしたら、fcitxが起動しなくなりました。

(firefox:3387): Gtk-WARNING **: GModule (/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-fcitx.so) initialization check failed: GLib version too old (micro mismatch)

(firefox:3387): Gtk-WARNING **: Loading IM context type 'fcitx' failed

(firefox:3387): Gtk-WARNING **: GModule (/usr/lib/x86_64-linux-gnu/gtk-3.0/3.0.0/immodules/im-fcitx.so) initialization check failed: GLib version too old (micro mismatch)

(firefox:3387): Gtk-WARNING **: Loading IM context type 'fcitx' failed

検索しても、困っているひとはあまりいないようですが…。以下のpackageを削除したら動くようになりました。

apt-get remove fcitx-frontend-qt5:amd64 libfcitx-qt5-1:amd64

Linux

Posted by Gordius