firefox が 古いversionのflashplayer pluginを使っていると言ってくる時

2017年9月18日

Debian Linux上でFirefoxを使っています。flashplayer pluginを更新したにもかかわらず、「お前のflashplayerは古いバージョンだよ」と言ってくる時があります。どうやら、firefoxがflashplayer pluginのversionを正しく認識していないようです。

firefoxのprofile folder (私の場合は/home/my_account/.mozilla/firefox/xxxxxxxx.my_account のような場所)に pluginreg.dat というファイルがあります。中身は

[PLUGINS]
libflashplayer.so:$
/usr/lib/flashplugin-nonfree/libflashplayer.so:$
11.2.202.440:$

とあります。このファイルを消して、firefoxを再起動すると

[PLUGINS]
libflashplayer.so:$
/usr/lib/flashplugin-nonfree/libflashplayer.so:$
11.2.202.442:$

と更新されました。これで正しくflashplayer pluginのversionが正しくfirefoxに認識されました。

参考にしたページ:
Firefox thinks I’m using and older Flash version