Ruby ocraで作ったexeを実行したら “libssp-0.dllが見つからない”と怒られた

Ruby ocraでexeを作って実行したら”libssp-0.dllが見つからない”と怒られました。

ほかにも”libgmp-10.dll”も見つからないと。

というわけで次のようにしたら動くようになりました。
ocra hoge.rb --dll ruby_builtin_dlls\libssp-0.dll --dll ruby_builtin_dlls\libgmp-10.dll

Ruby 2.6の時はこの手の問題は遭遇しなかったのですが、その後のバージョンだと遭遇しますね。

コメントを残す

このブログのコメント欄は掲示板ではありません。自分語りがしたい方はご自分のサイトでお願いします。

コメントはサイト管理者の承認制です。コメントの内容によっては必ずしも承認されませんが、それでも良ければコメントをどうぞ。

日本語が含まれない投稿は無視されますのでご注意ください。(スパム対策)

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください